Troubleshooting Scheduled Workflows

I have a collection of scheduled workflows that only fire intermittently.
I have no idea why they fire sometimes, and then not.
Is there any way that I can troubleshoot these? logs? messages? any recording of what the possible errors could be?

Any suggestions where I should start?
5 comments
Comment actions Permalink
Hello, Gareth,

do you use inCloud or standalone YouTrack? If standalone you can add the statement debug("message") in your code and see output in the workflow.log file in {home_folder}/.youtrackX directory.

You can use addComment("debug info") to see the debug info in a test issue comment.
0
Comment actions Permalink
Hello, Dmitry,

I tried adding debug messages as the very first step and very last - nothing is firing.

Looking at the workflow log file closer, each time I upload/update a workflow, there's a log entry for the upload, followed by a few lines of the following:
"HTML file without corresponding js file"

If I modify the downloaded zip (delete the old HTML) and re-upload the file via the workflow editor, the problem persists. same story if I do this via the web interface too.

I'm stumped - are the workflows corrupted?
0
Comment actions Permalink
You can go to the Administration > Workflows, click on a workflow, see its code and ensure that it's correct.

Please reduce a schedule rule condition to a trivial to get message in log. Thus you can debug the error by complicating condition step-by-step.
0
Comment actions Permalink
Hi Dmitry
Thanks, approached as you suggested. First obstacle was using "info(msg)" instead of debug :P

have managed to get some instances firing. The problem does not appear to be with the workflow per se, but rather the projects to which they are attached
I have already checked that the projects accept the workflows (no red lines on the workflow tab for the project)

some workflows, even simple scheduled workflows that only log, will not fire when attached to some projects, but fire just fine when attached to other projects. I've even tried creating a blank project, populating the fields with the same fields as the other projects, and that didn't even work...

I can't see what YouTrack is doing when it tries to run these things. any ideas what next?

Thanks for your help so far
0
Comment actions Permalink
Could you please attach workflow.log and youtrack.log?
0

Please sign in to leave a comment.