Youtrack will not fetch build numbers from TeamCity

I'm trying to get YouTrack to read build numbers from TeamCity, but I'm not able to get it to work. I run YouTrack and TeamCity on the same windows server, so time differences should not be an issue. YouTrack fetches all other info from TeamCity, so I can see the changes made in the build when opening the YouTrack issue. The only thing missing is the build number. I've also configured TeamCity to fetch data from Youtrack, and this works fine, too, so it seems that the integration is configured correctly.

Our YouTrack database is some years old (from YouTrack 4, I think) and has been properly upgraded to YouTrack 6 (now running on YouTrack 6.0). TeamCity installation is brand new (TeamCity Professional 9.0.1). Up until now I've created build numbers in YouTrack manually and assigned to issues, but now I want this to happen automatically. I've tried to use the original "Fixed in build" field for this (which has existing builds in it's value bundle), and I've also tried to create another build type field (with empty value bundle) without success.

Before setting up our production TeamCity server, I installed a new YouTrack 6 and a new TeamCity 9 on a test server, and got the integration to work without problems (including build number from TeamCity).

I used the same source control in both test and production cases (Visual Studio Online Git repository).

Can anyone please help me with this problem?

Please sign in to leave a comment.