JVM options ignored

Hello,

Since the last time that I updated my local installation of Youtrack that it doesn't assume the JVM options passed.

I am using a jar installation of build 43142 and I had to change how parameters are passed, because how they were before was rejected by youtrack.

I am using like this:

"C:/Program Files/Java/jdk1.8.0_131/jre/bin/java" -jar "C:/Program Files/Youtrack-2018.2.43142/youtrack-2018.2.43142.jar" --no-browser --data-dir="D:/youtrack/data" --backups-dir="D:/youtrack/backups" --logs-dir="D:/youtrack/logs" --base-url=https://youtrack.***.com --temp-dir="D:/youtrack/temp" --listen-port=8112 --secure-mode=tls --tls-server-cert-storage-type=keystore --tls-server-cert-folder="D:/youtrack/conf" --tls-server-cert-keystore-password=*** --tls-server-cert-keystore-key-alias=** --J-Djava.awt.headless=true --J-Xmx4g --J-Xms4g

But the --J-Xmx4g parameter is being ignored, in the statistics page it only shows 1GB.

Using like this it works:

"C:/Program Files/Java/jdk1.8.0_131/jre/bin/java" -jar "C:/Program Files/Youtrack-2018.2.43142/youtrack-2018.2.43142.jar" configure -J-Xmx4g

But if possible I would like to keep this configuration in the command line.

Is this a known issue or am I doing something wrong?

Thanks!

3 comments
Comment actions Permalink
Official comment

According to our documentation (https://www.jetbrains.com/help/youtrack/standalone/Configure-JVM-Options.html#set-jvm-options-jar), one minus only is necessary for the command line.

Comment actions Permalink

Lüba thanks for answering, but according to the same documentation page, in a jar installation is two minus or is that an error in the docs?

0
Comment actions Permalink

Hey, but that seemed to work. The documentation should be updated. Thanks!

0

Please sign in to leave a comment.