YouTrack not connecting to External Hub

I have set up a fresh install with Hub, YouTrack, and UpSource (all standalone) on a VPS.

I started with installing Hub first, it all is working fine. I then installed YouTrack, everything went smoothly, it connected to the external Hub during setup, I authenticated, it all passed and then YouTrack began. I ended up at a login page, tried my Hub credentials, and it failed. After a little bit of digging, I realized YouTrack was loading the native login page instead of the external Hub login page. I tried troubleshooting a bit and hit nothing but dead ends. I then setup UpSource, connected it to my external Hub, and it works just fine, connects to the external hub and everything. I thought maybe it was just faulty YouTrack setup, so I removed YouTrack and started completely over. Same exact outcome: YouTrack connects to external just fine during config, it lets me authenticate with no issue, and then I end up back at the native YT login, and still cant log in to it.

I checked my services in my hub, YouTrack is there, and trusted, just like my UpSource, although YouTrack doesnt have an icon associated with it like US does.

Is there anything else I can look at to troubleshoot this and maybe get some answers?

2 comments
Comment actions Permalink
Official comment

Does the issue still persist? Sorry for the delayed answer.

Comment actions Permalink

Unfortunately, after loading some repositories into my UpSource, I began running into more issues, which led me to realize that my VPS doesn't have as much RAM as I originally believed, and thus had to abandon this entire setup. I'm unable to confirm if the issues exists still, but at some point I will be upgrading and trying again.

0

Please sign in to leave a comment.