Importing github issues

Hi, I tried importing github issues based on the instructions here and the python script fails with this stacktrace:

  File "/Users/style/PycharmProjects/env2/bin/github2youtrack", line 11, in <module>

    sys.exit(main())

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrackutils/github2youtrack.py", line 131, in main

    csv2youtrack.csv2youtrack(params)

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrackutils/csv2youtrack.py", line 245, in csv2youtrack

    importer.import_csv()

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrackutils/csv2youtrack.py", line 275, in import_csv

    self.do_import(projects, new_projects_owner_login)

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/youtrackImporter.py", line 25, in do_import

    self._create_custom_fields(project_ids)

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/youtrackImporter.py", line 48, in _create_custom_fields

    self._create_field(yt_field[NAME], yt_field[TYPE], yt_field.get(POLICY), yt_field[AUTO_ATTACHED])

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/youtrackImporter.py", line 42, in _create_field

    create_custom_field(self._target, field_type, field_name, auto_attached, bundle_policy=attach_bundle_policy)

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/importHelper.py", line 50, in create_custom_field

    field = _get_custom_field(connection, cf_name)

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/importHelper.py", line 22, in _get_custom_field

    existing_fields = [item for item in connection.getCustomFields() if utf8encode(item.name).lower() ==

  File "/Users/style/PycharmProjects/env2/lib/python2.7/site-packages/youtrack/connection.py", line 851, in getCustomFields

    xml = minidom.parseString(content)

  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/xml/dom/minidom.py", line 1928, in parseString

    return expatbuilder.parseString(string)

  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/xml/dom/expatbuilder.py", line 940, in parseString

    return builder.parseString(string)

  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/xml/dom/expatbuilder.py", line 223, in parseString

    parser.Parse(string, True)

xml.parsers.expat.ExpatError: not well-formed (invalid token): line 2, column 31
4 comments
Comment actions Permalink
Official comment

Could you please let us know the name of the repository, if it's open?

Comment actions Permalink

It is not open. I can send attach the .csv files created (although they are quite big)

0
Comment actions Permalink

Could you please create a support ticket (right upper corner) and attach them there with the error

?

0

Please sign in to leave a comment.