Artifact not deploying will using Tomcat integration

Answered

Hi,

I'm new to posting on JetBrains forums. Is this the right place to ask questions about issues I am facing?

If it is, I am experiencing an issue with the deployment of artifacts in the Tomcat run configuration. Basically the issue is that no matter what I have tried, the artifacts I have added in the deployment are refusing to build. I have tried explicitly building them from the Build menu item as well as including them as items to be be built automatically with the project build, but the artifact build does not happen.

During the project build, the following error is generated:

[2019-04-14 03:03:39,513] Artifact UserAgentDetector: Error during artifact deployment. See server log for details.

The log at this timestamp is completely blank and is followed by an error that says the artifact could not be found for the web module. This is not an incredibly helpful series of error messages which would allow me to diagnose what's going on, so I hope someone else can see what might be going on or can share a strategy for solving it. I had similar issues when I tried to import an example project for my course.

This is for a university tutorial assignment which is due at the end of tomorrow. The course recommends using Netbeans, so given the short timeframe I'm going to try to get Netbeans going instead unless someone can help me today or early tomorrow. Normally I like JetBrains products for their intelligent approach to managing our projects, but the implementation of Tomcat integration in IntelliJ is looking pretty patchy to me at the moment. Maybe it is just my noob understanding of the integration that is in play though.




1 comment
Comment actions Permalink

IntelliJ IDEA support forum is at https://intellij-support.jetbrains.com/hc/en-us/community/topics/200382555-IntelliJ-IDEA-Users .

You can also submit a ticket at https://intellij-support.jetbrains.com/hc/requests/new .

It's hard to say what's the problem without a sample project.

0

Please sign in to leave a comment.