Error with docker image: Could not listen on 0.0.0.0:443

Completed

Hello everyone, I'm trying to move Youtrack installation from one server (Windows) to another (Ubuntu). As now I'll use Linux I want to use docker to set up Youtrack instance. 

My steps:

1) I've made a backup from the first server.

2) I've prepared new folders on the second server and run docker image:

docker run --rm -it --name my-youtrack \
-v /home/user/docker-services/youtrack/data:/opt/youtrack/data \
-v /home/user/docker-services/youtrack/conf:/opt/youtrack/conf \
-v /home/user/docker-services/youtrack/logs:/opt/youtrack/logs \
-v /home/user/docker-services/youtrack/backups:/opt/youtrack/backups \
-p 8080:8080 \
-p 443:443 \
jetbrains/youtrack:2019.2.56594

Container is starting successfully:

Starting YouTrack...
* Configuring JetBrains YouTrack 2019.2
* Made default base-url 'http://localhost:8080/' from hostname 'localhost' and listen port '8080'
* JetBrains YouTrack 2019.2 runtime environment is successfully configured
* Loading logging configuration from /opt/youtrack/lib/ext/log4j.xml
* Redirecting JetBrains YouTrack 2019.2 logging to /opt/youtrack/logs/internal/services/bundleProcess
* Configuring Service-Container[bundleProcess]
* Configuring Bundle Backend Service
* Configuring Configuration Wizard
* Starting Service-Container[bundleProcess]
* Starting Bundle Backend Service
* Starting Configuration Wizard
* JetBrains YouTrack 2019.2 Configuration Wizard will listen inside container on {0.0.0.0:8080}/ after start and can be
accessed by URL [http://<put-your-docker-HOST-name-here>:<put-host-port-mapped-to-container-port-8080-here>/?wizard_token=VRjOG9ApYdo3UZky5xZW]

3) I can access Configuration Wizard via browser too http://my-host.com:8080/?wizard_token=VRjOG9ApYdo3UZky5xZW Where I select "Upgrade" option, and select my backup file. But in the next step (when I select 'https' tab), I get an error:

Could not listen on address 0.0.0.0 and port 443. Verify that the existing YouTrack instance is stopped and that there 
are no other services that listen to the same address and port.

And I can't understand why I get this error?

There is a result of netstat:

user@myhost: sudo netstat -tulpn
[sudo] password for user:
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 909/systemd-resolve
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1261/sshd
tcp6 0 0 :::443 :::* LISTEN 26920/docker-proxy
tcp6 0 0 :::8080 :::* LISTEN 26908/docker-proxy
tcp6 0 0 :::22 :::* LISTEN 1261/sshd
udp 0 0 127.0.0.53:53 0.0.0.0:* 909/systemd-resolve 909/systemd-resolve

The problem only with docker, when I run Youtrack by "ZIP' method - all is fine.

What am I doing wrong? :[

3 comments
Comment actions Permalink

Hello, could you please create a support request to us and provide the full /logs and /conf folders?

https://youtrack-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66282

Thank you!

0
Comment actions Permalink

Sorry guys, but I've resolved the problem in other way. I just added an nginx instance as reverse proxy in front of Youtrack docker container. So now my nginx manage https traffic and communicate with Youtrack docker container via http.

Thanks for attention!

0
Comment actions Permalink

Thanks for the update!

0

Please sign in to leave a comment.