The images in notification emails are not displaying

Hi there,

when adding images to a comment, that is later emailed to a user by YouTrack, the images does not appear in the email. I've enabled images to be shown in email in my email client, but YouTrack seems to be making a first redirect to the Hub for login before showing images.

The screenshot below is an email containing an image, in the source of the email I can see that the image source is https://youtrack.samtanke.se/_persistent/1.png?file=83-855337&c=true&updated=1515518440735.

When I open this link in my browser it redirects me to https://youtrack.samtanke.se/hub/auth/login?response_type=token&client_id=0005bf68-19b7-4121-bb49-bd8d06fcd97a&redirect_uri=https:%2F%2Fyoutrack.samtanke.se%2Foauth&scope=0005bf68-19b7-4121-bb49-bd8d06fcd97a%20Upsource%20TeamCity%200-0-0-0-0&state=6af3cd56-c15b-4aa3-96a9-3026eee6ce0b

This seems to be related to that the browser does not have a YTJSESSIONID-cookie set. The hub-page will now set the YTJSESSIONID-cookie and if I try to visit the URL https://youtrack.samtanke.se/_persistent/1.png?file=83-855337&c=true&updated=1515518440735 again, the image is showing up. Even if I do not log in.

The problem I now have is that email clients does not seem to store any cookies and therefore no images is visible in the outgoing mails. Is this possible to fix in some way? Is there a setting in YouTrack I have missed? Our clients have problem with understanding the concept of opening links twice to be able to see images or attachments. 

 

 



1 comment
Comment actions Permalink
Official comment

Hello,

Unfortunately, this functionality is not implemented in YouTrack yet. However, we have a feature request: https://youtrack.jetbrains.com/v2/issue/JT-23972. Please vote/comment it to increase its priority.

Thank you for reaching out!

Please sign in to leave a comment.