Upgrade from YT 5 to 6.5 HTTP POST not supported

Hi,

we just tried to upgrade from YouTrack 5 to 6.5. Everything went well until we tried to login.
After we enter some credentials and click on the login button we get the following error message:
HTTP ERROR 405

Problem accessing /hub/auth/login. Reason:

HTTP method POST is not supported by this URL

Powered by Jetty://

We have reached the limit of our googeling skills and have no idea how to fix this problem, as everything worked fine with YouTrack 5.
We are running YouTrack 6.5.16433 on Ubuntu 12.04.3 with nginx 1.1.19.

Does anyone have an idea?

Sincererely
Thomas

9 comments
Comment actions Permalink

Same here on Windows 2012 R2

0
Comment actions Permalink

Hi Daniel,

my colleague said that he got it running with these setting:
https://confluence.jetbrains.com/display/YTD65/Linux.+JAR+in+Nginx+Web+Server
I did not get around to confirm it yet, but maybe it helps you.

0
Comment actions Permalink

I can verify that the instructions under https://confluence.jetbrains.com/display/YTD65/Linux.+JAR+in+Nginx+Web+Server solved the problem.
I think most critical for our system was the following line:
proxy_set_header X-Forwarded-Proto https;

2
Comment actions Permalink

Daniel Fisher, did you ever solve it on windows 2012? I have the exact same problem... All the solutions posted are for linux.

0
Comment actions Permalink

I can confirm this problem, and on apache2 it can be fixed with this instruction:

RequestHeader set X-Forwarded-Proto "https"

You need to have mod_headers enabled.

1
Comment actions Permalink

I have what's below, but I keep getting the error message.

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <httpErrors errorMode="Detailed" />
        <rewrite>
            <rules>
                <rule name="URL Rewrite" enabled="true" stopProcessing="true">
                    <match url="(.*)" />
                    <conditions>
                        <add input="{CACHE_URL}" pattern="^(https?)://" />
                    </conditions>
                    <action type="Rewrite" url="{C:1}://127.0.0.1:1001/{R:1}" logRewrittenUrl="true" />
                    <serverVariables>
                        <set name="HTTP_X_FORWARDED_HOST" value="{HTTP_HOST}" />
                        <set name="HTTP_X_FORWARDED_SCHEMA" value="https" />
                        <set name="HTTP_X_FORWARDED_PROTO" value="https" />
                    </serverVariables>
                </rule>
            </rules>
        </rewrite>
        <urlCompression doDynamicCompression="false" />
        <httpProtocol>
            <customHeaders>
                <remove name="X-Powered-By" />
            </customHeaders>
        </httpProtocol>
        <handlers>
            <remove name="ExtensionlessUrlHandler-ISAPI-4.0_64bit" />
            <remove name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" />
        </handlers>
    </system.webServer>
</configuration>

0
Comment actions Permalink

Could you please open a support ticket on this matter: https://youtrack-support.jetbrains.com/hc/en-us/requests/new ? It would be more convenient for detailed investigation.

0
Comment actions Permalink

I can also confirm this error can be firxed by adding the header "X-Forwarded-Proto" with value "https", whatever the proxy server is (Apache, NGinx, Express, Koa, ...). This happend because I was using a reverse proxy to forward requests from the internet (in HTTPS) to an instance of YouTrack Standalone using HTTP.

This header needs to be set for this HTTPS -> HTTP -> HTTPS bridge to work.

0
Comment actions Permalink

Lius, thank you for sharing the solution!

0

Please sign in to leave a comment.