Exposing locally hosted YouTrack externally, Hub appears to work, YouTrack still points to original URL

We have an standalone instance which had an internal URL.

We changed the IP to be in the DMZ IP. 

Logging into the hub resolves to the new IP, but youtrack still redirects to the original IP (machine name).

Changed the base URL, this didn't fix the problem. Any advice? 

7 comments
Comment actions Permalink

Hello,

Could you please elaborate how exactly and where you have changed base url? 

0
Comment actions Permalink

Hi,

We changed the base url for youtrack by shutting youtrack down from the command line and using the --configure --base-url command

We then restarted youtrack and checked what youtrack was saying the base url was in global settings. This hadn't changed so we modified it here as well to reflect that.

 

Cheers

0
Comment actions Permalink

Can anyone help us on this? We're pretty stuck.

 

Cheers

0
Comment actions Permalink

Hello,

Sorry for the delay.

What YouTrack version do you have? Do you use external or embedded Hub?

Thank you. 

0
Comment actions Permalink

One more thing, do you have proxy? If yes, please check that X-Forwarded-Host contains new IP address. 

0
Comment actions Permalink

Sorry for the delay.

We're currently on 2017.1 but in the process of upgrading and we (think) we are using an embedded Hub, the youtrack and Hub instances are on the same server.

No, we do not use a proxy.

Cheers.

0
Comment actions Permalink

Hello,

I am sorry for the delay. Could you please attach full Youtrack logs (https://youtrack-support.jetbrains.com/hc/en-us/articles/206546369-When-we-ask-you-to-provide-additional-details-logs-database-HAR-etc-) and configuration files (youtrack/conf folder)?

Thank you. 

0

Please sign in to leave a comment.