Stand-alone Installation on Linux - setting correct baseurl

Hi,

 

I've problems setting up YouTrack 2018 on my Ubuntu 14.04 server (managed with plesk). I've download the .zip-version, uploaded and extracted it on my server. Running the installer without browser support, the show baseurl is something like http://jiffybox...... instead of my domain (https://board.my-domain.de).

Is there a way to change the default base url (I've tried ./youtrack.sh configure --listen-address=board.my-domain.de

I want to access youtrack under https://board.my-domain.de. How can I accomplish this?

Thanks!

3 comments
Comment actions Permalink
Official comment

Hi,

Please refer to this link: https://www.jetbrains.com/help/youtrack/standalone/Reverse-Proxy-Configuration.html#Change_Base_URL.

The command should look like:

youtrack.sh configure --listen-port 1111 --base-url http://youtrack.mydomain.com:2222

Please let me know if it helps. 

Comment actions Permalink

Unfortunately it doesn't work..

Is there a way to access YouTrack directly via directory? Setting up my subdomain pointing on a specific folder within the YouTrack-directory?

0
Comment actions Permalink

Fabian,

Please submit a support request (https://youtrack-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66282) and provide there the following details:

1. How exactly is your domain https://board.my-domain.de supposed to be mapped to a server (through an A-record or CNAME record)?
2. Do you have any reverse proxy server to set up SSL?
3. I'd like to see real domain name if you don't mind (support request can be seen only by YouTrack support team - no sensitive data will be disclosed to any third parties) 

0

Please sign in to leave a comment.