Python api suddenly 403 Forbidden

Answered

Hi. We have been using the Python API for a while. Since the 18'th of october we are receiving:

youtrack.YouTrackException: Error for [/user/login]: 403: Forbidden: Forbidden

after using:

yt = YouTrack('https://***.myjetbrains.com/youtrack/', login='****', password='****')

I checked the user, api permissions, and whitelist. 

I also tried using a token:

yt = YouTrack('http://**.myjetbrains.com/youtrack/', token='perm:***')

but received:

TypeError: __init__() got an unexpected keyword argument 'token'

Our hosted youtrack version is:

Since no relevant changes were made by us, we suspect it could be due to the update to build 46581. 

 

The current library used is from https://github.com/JetBrains/youtrack-rest-python-library.git

revision (latest):

commit a64cac64c350218e223ddee940fe5b12f80206e9
Author: Alexander Buturlinov <imboot85@gmail.com>
Date: Sat Jul 21 15:44:09 2018 +0300

fix problem with wikified field

 

 

Thank you for your assistance,

 

-Russ.  

 

 

1 comment
Comment actions Permalink
Official comment

Hello,

I believe you've faced this bug: https://youtrack.jetbrains.com/issue/JT-49850. We have already fixed it and will provide the fix asap.
Meanwhile, you can use other methods of authentication (https://www.jetbrains.com/help/youtrack/standalone/api-log-in-to-youtrack.html) or unban guest account (please don't forget to revoke all guest user's permissions, including All Users group, to avoid data disclosure).
Hope it helps.

Please sign in to leave a comment.