Problem integrating Youtrack with Gitlab

Hello,

I'm currently setting up a dockerized YouTrack 2018.3 with a machine with Gitlab Community Edition 8.16.6 installed.

I think I created the previous steps correctly, first a Personal Access Token in Gitlab:

 

 

 

Second, the VCS Server,. something simple, local address, http and without ssl key:

 

 

Third,. I try to make a link between a repo from my Gitlab (in another machine but local network) to a project in Youtrack, example:

 

 

Connection to Gitlab seems ok, I put the private token and user and my repos are listed in combo. Click in Save button, but

whatever I've tried, the url conecction has a null between domain and repo name.

Example:

http://sgv34.sgnet.local/null/prueba

What I'm doing wrong??

  • I tried with individual repo owner and groups and I got same issue.
  • both installations are http
  • I had that config running time ago but I think the issue probably came when I installed Youtrack with docker image and deleted the previous local installation.

Any help will be much appreciated.

 

 

 

 

 

 

 

5 comments
Comment actions Permalink
Official comment

Hello,

Could you please create a support request (https://youtrack-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66282) and attach full YouTrack logs there and your version number? 

Thank you. 

Comment actions Permalink

Hello Anastasia,

I was able to integrate efectively with Gitlab 8.16.6, changing my youtrack docker image to the 2018.4.

That version provides a more easy integration but I have another weird issue, some gitlab projects with (I think) same attributes and properties does not linkwell with its youtrack counterpart and others links perfectly. Not linked ones are in same git group that ones working well,. could it be the project names?, some specific attribute in gitlab or youtrack project??

The error and logs with the bad ones are as:

 

And the logs:

Any help will be much appreciated.

 

 

 

 

 

 

 

0
Comment actions Permalink

What URL do you enter into "Repository URL" field? What do you see when going to this url in browser?

0
Comment actions Permalink

Hi,

that's the weird problem, both projects go to its gitlab page when we point to the urls in a browser:

First, the one that not links well

http://sgv34.sgnet.local/rdi-projects/Brecan

and another one that links perfectly:

http://sgv34.sgnet.local/rdi-projects/brecan-alg-service

And finally a snapshot of the webhook automatically created by youtrack in that last project:

I can't see the source code from gitlab but the exception is the previous snapshot:

 

Thanx

 

 

 

0
Comment actions Permalink

Hello,

I am very sorry for the delay. If the problem still persists, I'd ask you to create a support request (https://youtrack-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66282) and attach full YouTrack logs, screenshots from the previous message and a link to this post there.

0

Please sign in to leave a comment.