Switch all issues markup type

Answered

How to change default markup type  to markdown  everywhere?

YT for some reason often sets it to  "youtrack wiki" and I can't find how to change it globally. Really irritating!

 

8 comments
Comment actions Permalink

good question, specially considering that YT Wiki is deprecated

0
Comment actions Permalink

Hello,

Do you have any issue drafts with wiki markup selected? If yes, please delete them, open new issue form and select Markdown explicitly. After that, please check if markdown is persisted. 

If it doesn't help, please let me know some details about your YouTrack (inCloud/standalone, version number).

Please let me know the results. 

0
Comment actions Permalink

@Anastasia I do not know about OP, but I don't even know what is meant by `Issue drafts` - I sure have lots of Issues with wiki syntax selected (from the time before markup), sure will not delete them and have all history lost including spent time.

I am also not sure if you correctly understood the problem, it is not that the setting is not being persisted. The problem is that when a NEW issue is BEING created, the DEFAULT setting (very) often is the wiki syntax and so it must be changed - would be nice having a possibility to set the default for new issues.

Same is happening to comments!

I am using standalone (JAR) 2019.1

0
Comment actions Permalink

Thanks Anastasia, but can you tell me how to find issue drafts? Not sure I know how to find them.

I'm using incloud YT, account is https://28stone.myjetbrains.com

 

0
Comment actions Permalink

Drafts can be found on the new issue creation form, see below:

Drafts are issues which are not created yet. If you don't need them, please delete them all, navigate to the issue creation form and select markdown. This should set markdown to be a default markup type. 

If you do need the drafts, please try changing the markup to markdown explicitly there (in each draft). 

Please let me know the results. 

1
Comment actions Permalink

Thanks, it looks like it worked.

0
Comment actions Permalink

Did not work for me.

  1. Deleted all Drafts
  2. Opened existing Issue
  3. Checked it is set to Markdown (just to be sure)
  4. Selected 'New Issue' > 'subtask of'

The New Issue form opens and 'Youtrack Wiki' is selected

0
Comment actions Permalink

It may so happen that you have comments drafts with wiki markup selected. This situation will be fixed in the scope of https://youtrack.jetbrains.com/issue/JT-52345 (the fix will be available in one of the next bug fix updates). 

0

Please sign in to leave a comment.