How to edit "Time Spent"?

Just decided to enable Time Tracking for a client project.  Is there a way to manually edit Time Spent entries?  I've made a duplicate entry and need to remove one of them, and can't find a way to do this.  I can see the roll-up info in a report, but no way to get to an individual entry to change/remove it.




Hello Ray,

You need to open Spent Time tab in the activity stream under the issue (hourglass icon), hover the cursor over the necessary entry, and press Edit (pencil icon). The entry will expand, and you'll see the Delete button.


Thanks Alisa! Of course, now that I see that the hourglass icon at the top was not enabled, enabling it makes everything very clear now! Your instructions were right on... I appreciate the help.


Alisa Kasyanova I don't have the pencil beside the spent time.

I'm the project owner with the right privilege.
And we have a gantt chart that has that wrong spent time on it :(


Hi Richard,

Please check if Time Tracking is enabled in the RO project. It seems likely that spent time was entered directly into the custom field Spent time and not via the Add spent time button (see here). If everything is alright there, it might be possible that your role in the project does not contain the permission to read and update work items.

Regarding the Gantt chart, do you have the Estimation and Start date fields specified in the advanced settings of the chart?


Stanislav Dubin Confirmed time tracking is enabled.

I'm project Admin
Ah, I believe that the time was entered directly into the Spent time field. But that field can't be edited. Is there a way to fix that?

In Gantt, Start date field is not available in YouTrack Cloud that I can find. And Star date field can't be added in the project fields.



Richard, sorry for the delayed reply.

To avoid confusion, it is generally not recommended to edit the parent task when it comes to time tracking, best to keep both estimates and time spent in the subtasks and rely on the automatic summing up in the parent task.

You can disable time tracking in the project temporarily to get the field to be editable again. Once you change the field to no value, you can then go ahead and add another work item in the subtask. That should have the effect of synchronizing the spent time again so the parent task reflects the sum of spent time of its subtasks. This is also likely why you don't see the correct coloring on the Gantt chart bar, so once you have that set up it should be fixed as well. If something still feels off, please provide screenshots of the spent time values for the parent task and all its subtasks. Feel free to submit a private request, if you like.


Please sign in to leave a comment.