Members of a project which have the developer role cannot see agile board card fields

Hey,

I'm having a few issues with the agile board permissions. I'm trying to let the role developer see the custom card fields.

Members currently see this:

When I would like them to see this:

I have tried changing permissions and the only one I could find which allowed the members with the developer role to see these custom card fields is Update Project (see image below), but then they can update the whole project and that isn't some thing I want.


The agile board permissions are as follows:

Giving the SD20-1 team permissions to edit the board doesn't give them permissions to see the custom card fields either (and I don't want them to edit the board so that's a good thing).

Any help would be appreciated.

Kind regards,

Thomas

3 comments
Comment actions Permalink

Hello Thomas,

Please excuse me for the delayed answer. If you wish to receive answers faster, you can create a request to our support.

Could you please check whether there are any errors in the browser's developer console when users (who do not see the fields on cards) open the board? Please also share a screenshot of the Agile boards > board > Board settings > Card section.
Thank you in advance.

1
Comment actions Permalink

Hey there,

Board settings (it's a different board than the one in my first post but none of them work):


Console of a user assigned to the board:
https://pastebin.com/5q5LG87n

0
Comment actions Permalink

Hello Thomas,

The issue appears because you have selected the `Type` field in the custom fields for the board, but there is no such field in the project. As I can see on the sent screenshot, there is the `SD20-6` project shown near the `Priority` field, but no projects near the `Type` field. I suppose that your SD20-6 project previously had this field, but you have replaced or removed it.

So, the project `SD20-6` that is used for the board doesn't have the said field, thus developers cannot actually see it, and have the js-issue that causes rendering issues while admin can see it without any issues (most probably because this field is used in another project or something where the admin have access).

Please remove the `Type` field from the Card settings. After that, developers should start seeing the cards properly.

0

Please sign in to leave a comment.