Created a new project, but the project is not available in knowledge base

Using the latest builds of YouTrack and Hub.  I created a new project, and it appears in YouTrack as available when I want to create a new issue. So everything is OK.

But when I go to the Knowledge Base and click on New Article, the new project is not listed. All I see are the existing projects.

Any ideas?

5 comments
Comment actions Permalink

Hi!

Are you trying to create an article under the system admin account?

Please also try opening the Hub integration page (we have removed the link from the interface, but you can open it via direct URL servername.com/admin/ring), then click Sync, Export, Invalidate caches, and then Run diagnostics. Then apply quick fixes, if any, and check whether the project appears in the list.

0
Comment actions Permalink

If I log in as the system admin account - username "admin" - then I can create a knowledgebase article under the new project.

If I log in as my normal user (which has project owner and system admin roles), then I cannot.

What roles/permissions are required to create knowledgebase articles?

It may be some other problem with the hub - I am also having a problem where a new user that I have created cannot log in. At all.

I did have problems when upgrading Hub and YouTrack to the latest versions - both upgrades failed, and left the installations in a broken state, refusing to start. I had to uninstall them and then re-install and load the backups to get everything working again, so something may still be broken.

0
Comment actions Permalink

A user must have a Create Article permission to add knowledge base articles under the project.

What error appears when the new user cannot log in? Password change doesn't help, am I correct? Have you tried the Sync, Invalidate Caches, and other steps that I have mentioned? If there is some information that is not synchronized between Hub and YouTrack, they should fix it.

0
Comment actions Permalink

Thanks - adding the "Create Article" permission fixed my problem. For some reason that permission was missing from the default "Developer" role that was being assigned to the new user.

The login problem is strange -- I am not getting an error message. I created the new user via the Hub.  I can log in as the new user via the Hub URL.  But if I try logging in via YouTrack it just refreshes the login page.

From the YouTrack issues list (with "Login" showing at the top right), I click the Login button.  The pop up "Log in to YouTrack" window appears.  I enter the username and password, and click "login", but the login popup just refreshes. No message is shown. If I deliberately enter the wrong password, I get a red "Incorrect username or password" message.

If I log in (as the new user) via the Hub URL, and then navigate to YouTrack by clicking the "squares" icon at the top right of the Hub page and then clicking on the YouTrack icon,  I get to YouTrack ... but apparently as a "guest" user. YouTrack displays a blue "Login" button indicating I am not actually logged in.

 

0
Comment actions Permalink

Have you tried the Hub integration > Sync, Export, Invalidate caches, and Run diagnostics steps? Does this error appear in any other browser (or incognito mode)?

0

Please sign in to leave a comment.