Error: Failed to refresh authorization

Hello everyboy,

We are a very small team, and We are having a blast with youtrack so far.

But, we do have a recurring problem. Very often We do receive this error.

The funny thing is that, if We do refresh the page the error disappears, "Try again" does nothing, "Postpone" just closes the window.

Our setup:

Server side - Youtrack 2022.2.51283 as a docker container behind Traefik reverse proxy v2.8

Client side - Windows 10 , Microsoft Edge latest version

Any ideas?

Thank you for your attention

5 comments
Comment actions Permalink
Official comment

Hi!

I'm Sergey from the YouTrack team.

Thank you for contacting us. I'm happy to help you.

Firstly, regarding logouts, potential reasons and fixes — we have an article that covers a majority of the cases: https://youtrack-support.jetbrains.com/hc/en-us/articles/360000058770-I-keep-getting-logged-out-of-YouTrack

behind Traefik reverse proxy v2.8

One of the logout reasons is an incorrect proxy setup. We don't have any official documentation for Traefik, so I can't share specific instructions. However, I recommend taking a look at the following doc: https://www.jetbrains.com/help/youtrack/server/Reverse-Proxy-Configuration.html. Specifically, it provides details about headers and how to pass them correctly. You need to make sure that it's implemented in your reverse proxy config as well. Or just move to the reverse proxy server we have the instructions for and copy them as is, just replacing data with yours.

If any questions appear, please let me know.

Comment actions Permalink

Thank you very much Sergey, I did infact missed some of the details when I was configuring Traefik.

I will try to implement it all and get back to you with what was wrong in my configuration, for the sake of shared knowledge.

 

Giacomo

0
Comment actions Permalink

Sure, thanks! 

And if any questions appear, feel free to ask. 

0
Comment actions Permalink

So I think I figured it out.

I am testing the setup right now, but the mentioned authorization error is gone, and browsing it's way faster.

 

I assume that who is reading this is somewhat familiar with Traefik version2 and above.

Here is what I've done.

I do have global http to https redirection so you won't see a label specifing that aspect, anyway, theese are my youtrack labels:

      - "traefik.enable=true"
      - "traefik.http.routers.youtrack.rule=Host(`youtrack.domain.com`)"
      - "traefik.http.routers.youtrack.tls=true"
      - "traefik.http.routers.youtrack.middlewares=customHeaders@file"
      - "traefik.http.services.youtrack.loadbalancer.server.port=8080"
 
You see that "customHeaders@file" in the middlewares declaration for the youtrack router, it is defined in the dynamic.yml configuration file.
This is the bit about customHeaders in the dynamic.yml :
 
customHeaders:
      headers:
        browserXssFilter: true
        contentTypeNosniff: true
        customFrameOptionsValue: "SAMEORIGIN"
        customRequestHeaders:
          X-Forwarded-Proto: "https"
        stsIncludeSubdomains: true
        stsPreload: true
        stsSeconds: 31536000
 
This took me a lot of time to figure it out, since Traefik it's very powerfull but it's documentation, imho, it's not very clear and lacks a lot of real world examples, leaving you with a set of options but it's unclear how to really use them.
 
Anyway
Thank you again Sergey.
 
0
Comment actions Permalink

Thanks for the update. Happy to hear that you've resolved the issue! 

0

Please sign in to leave a comment.