Cannot create mapping for integration with TeamCity

I'm trying to setup YouTrack with a new TeamCity instance but I'm unable to create the mapping after connecting the two.  I can get the connection established and working no problem, but the the "Save" button is always greyed out, preventing me from creating a new mapping.  This issue occurs when attempting to create the mapping from both Project and Server settings.

May be related to: JT-60326

Are there any required fields I need to fill?  Or maybe a manual way to add it via cli or file edits?

3 comments
Comment actions Permalink

Hi! 

I'm Sergey from the YouTrack team. 

You need to select a TeamCity build as well, as this is the key configuration parameter. 

1
Comment actions Permalink

That worked, thank you.  Do you think you could add required field indicators to this dialog in the future?

0
Comment actions Permalink

Thanks for your response.

Glad to hear that it helped. As for the required fields indicator, I created a separated task for that: https://youtrack.jetbrains.com/issue/JT-71091/Highlight-required-fields. Please feel free to vote for this issue. This helps us gauge how much impact this change will have on our customer base, and you’ll also get subscribed to the issue’s notifications. To do so, sign in to JetBrains YouTrack and hit a thumbs-up icon.

0

Please sign in to leave a comment.