Automatic Timer counts time on weekends and nights

Hi Everyone,

 

I'm using a standard time tracking workflow, in the global settings it is indicated that we have 8 hours working day, and Sunday and Saturday are days off.

Despite of that, when I put a test task in 19:24 Friday evening, youtrack counts 8 hours every day, and Monday morning it says that the task were in work for 24 hours. 

 

It's does not matter when I put my task in progress, in an evening or in a morning.
I've tried this workflow in other days as well. And no luck — 8 hours count every 24 hours, including off hours.

The story the same on standalone installation as well. 

 

Any advise on this?

5 comments
Comment actions Permalink
Official comment

Hi Alex, could you please attach screenshots of your global Time Tracking settings + the time tracking settings of that particular project?

Also, let us know which workflow you're using, is it the 'In Progress Work Timer'? Have you changed this default workflow yourselves in any way?

Are you currently using an InCloud YouTrack instance or a standalone installation? If you're in the cloud, let us know the name of your instance.

Thank you!

 

Feel free to submit a support request to answer these questions and provide additional details if you consider any data to be sensitive.

Comment actions Permalink

Hello, I am having the same issue, in "Time Tracking" settings days are set only weekdays, 8 hours per day, and im using "In Progress Work Timer". If I set "In progress" on Friday and stop it on Monday, it will count me 2 days of work. Any ideas?

0
Comment actions Permalink

Hello,

Thank you for reaching out. The "in progress work timer" workflow doesn't consider weekends and nights by default. You can enhance it though by hardcoding your working days and hours and adjusting the calculated time according to those conditions. Please let me know if it helps.  

0
Comment actions Permalink

I haven't changed any workflow for "In progress". 
Would be great if you could provide me an example how to enhance this workflow to ignore weekends or include only working days and hours.

0
Comment actions Permalink

Hello,

The intervalToWorkingMinutes method calculates time according to the Time Tracking settings. So, would you please check that your working time is set correctly?

 

 

0

Please sign in to leave a comment.