Text being overwritten as I type

Sometimes, and seemingly at random, typing text overwrites anything anything in front of the caret, e.g., if I have the line "print 'Hello world'" and I place the cursor in front of 'Hello world' to and type an opening paren, the line will become (Hello world' - i.e., the opening quote has been typed over. If I continue to type, I will continue to replace the characters in the string. This continues until I restart pycharm, and sometimes happens a few times a day, and I am not sure why. Is this a setting that I am turning on with a key combination, or is it a bug? Thank you!

18 comments
Comment actions Permalink

Hello,

I hope you've already found the solution but just in case (and for other people with the same issue),

To toggle this feature on/off you can use the 'Insert' key on your keyboard

 

Hope this helps.

 

9
Comment actions Permalink

I don't have an "Insert key" on my keyboard.  So now what?

1
Comment actions Permalink

Hello,

You can simulate 'insert' with different shortcuts depending on your keyboard and OS. Hope it helps.

0
Comment actions Permalink

I consider it a bug to require a key that is a bit exotic on Macs, which many developers use, to recover from a mysterious entry to overwrite mode in the first place. 

0
Comment actions Permalink

virtual keyboard. you should have one in the accessibility in the start menu 

 
0
Comment actions Permalink

Wait, this isn't being treated as a bug? It is seriously annoying and has been happening to me for a while. It happens somewhat randomly but easily 10 times a day. I think it usually after I've backspaced everything in the evaluate expression box, it'll enter this "insert" mode.

 

I'm definitely not triggering it with my own press of "insert" (since, like the previous poster, I don't have such a key). It makes the "evaluate expression" box vastly more irritating to use, when otherwise it would be an extremely helpful feature.

 

Telling us we should open up a virtual keyboard in order to fix this clear bug in the evaluate expression box is, frankly, pretty unacceptable.

-1
Comment actions Permalink

Yes, because it's not a bug. If you press insert or the insert shortcut it will override the text you type, whether using JetBrains product or any regular text editor. If you don't want it to happen you should disable the shortcut at the operating system level. It's unrelated to the software you are using.

1
Comment actions Permalink

Save hassle, stay ignorant/innocent , and restart your computer. It worked for me :)

1
Comment actions Permalink

I'm getting the same issue (and I am not in "insert" mode).

Basically, when I try to write text in the built-in terminal in pycharm, any text to the right of it does not appear to shift to the right as you’d expect, but rather appears to be overwritten while I am typing. And then when I press enter the command executes normally, without the text being overwritten. For example, if I type
123 456
Then scroll back and insert 789 before the 123, the prompt looks like
789 456
but it actually executes
789123 456
This bug basically makes pycharm unusable. Is there any solution to this problem?
0
Comment actions Permalink

Hey, try checking and disabling the VIM plugin. 

Press: Ctrl+Alt+S. Preferences -> Plugins -> Installed. Then check if you have that plugin installed. If so disable it!
Source: https://intellij-support.jetbrains.com/hc/en-us/community/posts/207026025/comments/360000100650

3
Comment actions Permalink

This happens to me when my cursor is directly behind text, example:

 

    When typing I will overwrite the following.|text

    When typing I will overwrite the following.with.this

when what I really wanted was:

    When typing I will overwrite the following.with.this.text

 

I do not have VIM plugin installed, and I do not use INSERT

0
Comment actions Permalink

On Windows, the number key for zero (key = 0) also serves as a toggle for Insert/Overwrite text entry mode. On some keyboards, the 0 number will also have 'insert' on the key. It's easy to accidentally hit the zero key, if you use the arrow keys to navigate around text.

If you hit the 0 key, you toggle into Overwrite mode. Hit the key again and you toggle to Insert mode.

4
Comment actions Permalink

Acid Inc

Thanks a lot. Your tip worked for me. 

It was just deactivate the IdeaVim plugin and the typing came "normal" again. 

 

ur a hero!

0
Comment actions Permalink

I don't know if it's been solved but if you press number lock and then press "0" it will work 

0
Comment actions Permalink

Acid Inc Ferrotodv

Thanks! It is now fixed. This is bugging me for a long time and it is now okay.

0
Comment actions Permalink

I have the same issue. Rider keeps overriding the same character. But the behaviour seems to be another one. 

First: It only happens in Rider. Every other program is working just fine. 

Second: After every typed character the one gets removed, even when I don't type a new one.

Any idea what that could be?

1
Comment actions Permalink

I don't know what happened but after I've unselected a few plugins (not VIM which I didn't had installed) and restarted Rider it worked again :-/ *Strange*

 

0
Comment actions Permalink

Hello Max,

this is a thread about another JetBrains product, YouTrack. If you need support from the Rider team, please feel free to post to their forum here: https://rider-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=97145

0

Please sign in to leave a comment.